24.02.2024, 05:29 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
Titel: X-config. for laptop w/ integrated Intel Extreme 2 graphics?  BeitragVerfasst am: 02.06.2009, 17:02 Uhr

Anmeldung: 07. Mai 2005
Beiträge: 153

I'm having problems getting graphics run correctly on Kanotix on the following Samsung Q25 notebook: http://www.discsoft.de/Produkt_Pdfs/Not ... ngebot.pdf

According to KDE (Info module -> PCI) the particular graphics card is Intel 82852/82855 GM/GME/PM/GMV processor to I/O Controller (rev 2).... In short it is also referred to as Intel 852GM/855GM.

Although the system is usable in all other respects the effects include rapidly flickering text, affecting most applications, xterm, browsers and almost everything. The display problems is not limited to text. It applies to probably all graphical widgets, window decorations etc.

At first, I thought there may be a hardware defect but then I tested various Linux's and found that the same to appear more or less predominantly on several distros while some distros display everything perfectly. For example, the problem affects the latest Debian netinstall and various flavors of Ubuntu as well as the latest development version of Kanotix. It is not limited to a particular desktop environment (eg. KDE vs. Gnome etc). It happens on all or none of the window managers of any particular installation. Distros where the graphics work perfectly include Damn Small, Linux Mint and an earlier version of Knoppix. Probably earlier Kanotix's are OK too, but I did not test. And Windows XP works fine. So, there's no hardware defect.

I could find very little information with regards to the problem via search, so perhaps not many people running Linux have this particular notebook. Although, according to one post (originally in Polish language) there's a Ubuntu user who experienced the same problem with the same notebook: http://translate.google.com/translate?j ... ry_state0=

The user eventually solved the problem by first installing the driver for Intel i810 and thereafter changing the graphic card driver via a GUI tab in System -> Admin -> Screens & Graphics -> Graphic Card. I don't know of a possibility to change the default X-windows graphic card driver via a desktop configuration widget on Kanotix/KDE or on any similar set-up. Perhaps that tab option is specific to Gnome/Ubuntu. I guess the closest equivalent in KDE is "Configure Display" in the Control Center, but of course, there is no tab to select a default graphic card driver here.

According to KPackage the current X11 graphic card controller in use for my system is "xserver-xorg-video-intel" (version 2:2.3.2-2+lenny6). It supports a variety of Intel chipsets but the number "855" alone does not appear amongst them. The closest in the description is "i855" series chips. Maybe its the same.

A commenter on the Polish blog suggest as the xserver-xorg-video-intel driver is a successor to xserver-xorg-video-i810 that the i810 version works better with the particular hardware or chipset, because that was what was supported earlier, before the current driver. This suggests that Debian's latest version of the Intel driver simply breaks the graphics on this particular hardware and possibly other similar systems and that the error is effectively also replicated amongst various distributions, Kanotix included.

How is it possible to test the earlier driver on Kanotix? The actual xserver-xorg-video-i810 is installed (in addition to xserver-xorg-video-intel). The i810 version is listed in a folder named 'oldlibs' in KPackage. It is also written in its description that it conflicts with the xserver-xorg-video-intel driver.

My first thought was to simply to deinstall the later driver via KPackage and then install the earlier i810 version. However, this is not possible, because apt-get install xserver-xorg-video-i810 or KPackage insists on also installing xserver-xorg-video-intel. For some reason Lenny is very persistent in using the latest driver. So there's no way to install the earlier version only via the Debian package manager. At least I have both drivers on the system, so I only need to know how to configure X11 to use the old driver instead of the new one.

I tried dpkg-reconfigure xserver-xorg but this does not work for graphics. Instead it runs through a series of keyboard options.

I also tried running dpkg-reconfigure xserver-xorg-video-i810 which reports no success or failure error code, nor does it have any effect.

As far as I understand, the problem is lack of backwards compatibility with the new Intel driver that is shipped with Debian. I guess the remaining solution is to recreate an /etc/X11/xorg.conf file from scratch, manually. But the file on the installed Kanotix looks very different from the one on the above Polish blog or any other X-config files I've seen. There are various sections within which appears to be loading in Debian defaults. Does anyone know a good manual for configuring xorg.conf?

Any advise how this may be fixed would be much appreciated. I have attached some screenshots of possibly relevant sections from the KDE Info Center of the notebook.

Many thanks,

 Dateigröße:  52 KB
 Angeschaut:  107755 mal


 Dateigröße:  64.35 KB
 Angeschaut:  107754 mal


 Dateigröße:  39.88 KB
 Angeschaut:  107754 mal


 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.